<!DOCTYPE HTML>
<html lang="pl">
<head>
<script>
    document.cookie = "__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/"; 
    var setNptTechAdblockerCookie = function(adblocker) { 
        var d = new Date(); 
        d.setTime(d.getTime() + 60 * 5 * 1000); 
        document.cookie = "__adblocker=" + (adblocker ? "true" : "false") + "; expires=" + d.toUTCString() + "; path=/"; 
    }; 
    var script = document.createElement("script"); 
    script.setAttribute("async", true); 
    script.setAttribute("src", "//www.npttech.com/advertising.js"); 
    script.setAttribute("onerror", "setNptTechAdblockerCookie(true);"); 
    document.getElementsByTagName("head")[0].appendChild(script); 
</script>    <meta charset="utf-8">
    <meta name="description" content="Skutki spowolnienia gospodarki dotykają nawet takie spółki, jak Amazon i Apple. Wszystko wskazuje na to, że wyniki za II kwartał 2022 r. okażą się dalekie od tych, to jakich inwestorzy się przyzwyczaili.">
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0">
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">
    <link rel="canonical" href="https://www.pb.pl/sektor-technologiczny-czekaja-trudne-chwile-1156828">
        <meta name="cXenseParse:author" content="Mikołaj Śmiłowski" data-separator=","/>
        <meta name="cXenseParse:bbp-section" content="Puls Inwestora" data-separator=","/>
        <meta name="cXenseParse:bbp-category" content="Makroekonomia,Akcje" data-separator=","/>
        <meta name="cXenseParse:bbp-access" content="closed" data-separator=","/>
        <meta name="cXenseParse:bbp-issue" content="141/2022" data-separator=","/>
        <meta name="cXenseParse:pageclass" content="article" data-separator=","/>
        <meta name="cXenseParse:recs:publishtime" content="2022-07-26T18:00:00Z" data-separator=","/>
        <meta name="cXenseParse:bbp-pubdatetime" content="26-07-2022 20:00" data-separator=","/>
        <meta name="cXenseParse:articleid" content="1156828" data-separator=","/>
        <meta name="cXenseParse:image" content="https://images.pb.pl/filtered/a2ef19e6-37a3-43e5-9411-35f2ee96cf43/90347d97-13c7-5d21-8cad-9823627b58dc_og_1200_630.jpg" data-separator=","/>
        <meta name="cXenseParse:description" content="Skutki spowolnienia gospodarki dotykają nawet takie spółki, jak Amazon i Apple. Wszystko wskazuje na to, że wyniki za II kwartał 2022 r. okażą się dalekie od tych, to jakich inwestorzy się przyzwyczaili."/>
        <meta name="cXenseParse:title" content="Sektor technologiczny czekają trudne chwile"/>
        <meta name="cXenseParse:url" content="https://www.pb.pl/sektor-technologiczny-czekaja-trudne-chwile-1156828" data-separator=","/>
<meta property="og:locale" content="pl_PL">
<meta property="og:site_name" content="pb.pl">
<meta property="og:type" content="article">
<meta property="og:title" content="Sektor technologiczny czekają trudne chwile">
<meta property="og:description" content="Skutki spowolnienia gospodarki dotykają nawet takie spółki, jak Amazon i Apple. Wszystko wskazuje na to, że wyniki za II kwartał 2022 r. okażą się dalekie od tych, to jakich inwestorzy się przyzwyczaili.">
<meta property="og:url" content="//pb.pl/sektor-technologiczny-czekaja-trudne-chwile-1156828">

<meta property="og:image" content="https://images.pb.pl/filtered/a2ef19e6-37a3-43e5-9411-35f2ee96cf43/90347d97-13c7-5d21-8cad-9823627b58dc_og_1200_630.jpg">
<meta name="twitter:image" content="https://images.pb.pl/filtered/a2ef19e6-37a3-43e5-9411-35f2ee96cf43/90347d97-13c7-5d21-8cad-9823627b58dc_og_1200_630.jpg">

<meta property="fb:pages" content="383296170843" />
<meta name="twitter:title" content="Sektor technologiczny czekają trudne chwile">
<meta name="twitter:site" content="@puls_biznesu">
<meta name="twitter:card" content="summary_large_image">

<meta name="twitter:description" content="Skutki spowolnienia gospodarki dotykają nawet takie spółki, jak Amazon i Apple. Wszystko wskazuje na to, że wyniki za II kwartał 2022 r. okażą się dalekie od tych, to jakich inwestorzy się przyzwyczaili.">

<meta name="robots" content="noarchive">
    <meta name="google-site-verification" content="jU3zgoN2Yer7QP3whPTCtDM3wIyzfmltMohgmW70OVA">

    <script src="https://apis.google.com/js/api:client.js"></script>
    <link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet" type="text/css">

    <title>Sektor technologiczny czekają trudne chwile - Puls Biznesu - pb.pl</title>

<link rel="preload" href="/static/font/lato-black.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/static/font/fontawesome-webfont.woff2?v=4.7.0" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/static/font/tiemposheadline-bold.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/static/font/lato-regular.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/static/font/lato-light.woff2" as="font" type="font/woff2" crossorigin>    
    <link href="https://fonts.googleapis.com/css?family=Lato:400i,700&amp;subset=latin-ext" rel="stylesheet">
    <link rel="stylesheet" type="text/css" href="/static/css/npb.min.css?v=220509
">
    <link rel="stylesheet" type="text/css" href="/static/css/jquery-ui.min.css">
<link rel="stylesheet" href="/static/css/npb.a.min.css?v=2007151">
<link rel="stylesheet" type="text/css" href="/static/css/ns.min.css?v=220508
">
    <link rel="shortcut icon" href="/static/img/favicon/favicon.ico" type="image/x-icon">
    <link rel="icon" href="/static/img/favicon/favicon.ico" type="image/x-icon">
        <link rel="manifest" href="/manifest.json">

<script>

var dataLayer=[];sas_target='';dataLayer.push({'author': 'Mikołaj Śmiłowski', 'section': 'Puls Inwestora', 'category': 'Makroekonomia|Akcje', 'newsId': 1156828, 'publicationDate': '2022-07-26', 'publication_status': 'closed', 'gate_status': '1'});
window.google_anal_push = function google_anal_push(event) {
    try {
        // id': article ID:'+ID_ARTYKUŁU, // W INNYCH PRZYPADKACH: 'Page: '+window.location.href,
        var Promotions = {
            'promotions': [{
                'id': 'Page: ' + window.location.href,
                'name': event.name,
                'creative': 'display',
                'position': 'footer'
            }]
        };

        var EventData = {'promoView': Promotions};

        if (event.click === 1) {
          EventData = {'promoClick': Promotions};
        }

        dataLayer.push({
            'eventCategory': 'E-commerce',
            'eventAction': 'Akcje rozszerzonego e-commerce',
            'eventLabel': event.eventLabel,
            'eventValue': 0,
            'eventNonInteraction': true,
            'event': 'zdarzenie_enh_ecom',
            'ecommerce': EventData
        });

    } catch (error) {
        console.error(error.message);
    }
};</script>
                <script type="text/javascript">
var npb=npb||{};npb.client_data={user_newsletters:[],articles_in_stash:[],user_id:0,welcome_text:"Czytelniku",access_type: null,offer_slug: null,past_offer_slug: null,email: null,publication_status: "closed",access_dates:null,has_trial:false,had_subscription:false,sub_end:null,sub_fix_range_end:null,is_recur:null,recur_deactivate:null,recur_fix_range_deactivate:null,show_box: 0,article_id: 1156828,isp:[]};ghmxy_identifier ='p8ZFz7d0GcYQ06oZLC.kxqRvDqs6LQ_yR14I61iWYuP.07';var moderators=['bbe58039-2393-43bf-be28-9ead00c1cbef', '36b2e113-ac9d-4017-b5a0-4247d7651c43', '33d2c058-132b-4d31-84d4-42b054fe2fca', 'c5e92afd-630b-48a3-bb99-ce5b584e928d', '4ea550a6-94f6-4bd1-aa87-7dfd656f0db2', 'c9a77498-7798-4693-8cf4-ea67b881a40b', 'c1b16ac8-33fc-4403-96e0-4e47b1e5bec6']</script>
<style>.async-hide { opacity: 0 !important} </style>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PTPFH5');</script>


<script async src="https://cdn.onthe.io/io.js/CtdP6K1ijpjI"></script>
<script type="text/javascript">

if (typeof npb == 'undefined') {
    npb = {client_data: {access_type: ''}};
}

if (npb && npb.client_data.access_type === 'premium' || npb.client_data.access_type === 'basic') {
    user_status = "paid";
} else if (npb && npb.client_data.access_type === 0) {
    user_status = "free_reg";
} else {
    user_status = "free_unreg";
}
window._io_config = window._io_config || {};
window._io_config["0.2.0"] = window._io_config["0.2.0"] || [];

window._io_config["0.2.0"].push({
    page_url: "https://www.pb.pl/sektor-technologiczny-czekaja-trudne-chwile-1156828",
    page_url_canonical: "https://www.pb.pl/sektor-technologiczny-czekaja-trudne-chwile-1156828",
    page_title: "Sektor technologiczny czekają trudne chwile",
    page_type: "article",
    page_language: "pl",
    article_authors: ["Mikołaj Śmiłowski"],
    article_categories: ["Puls Inwestora", "Makroekonomia", "Akcje"],
    article_type: "closed",
    article_word_count: "1285",
    article_publication_date: "Tue, 26 Jul 2022 20:00:00 +0200",
    user_status: user_status
});

</script>



<script type="text/javascript">sas_target+='article_id=1156828;article_pub_date=2022-07-26;article_char_count=15324;author=mikolaj_smilowski;section=puls_inwestora;category=makroekonomia;category=akcje;';</script>

<script type="text/javascript">var _smid="en2eym7pqp9kfwsq",_smcustom=!0;!function(t,e,s){e=document.createElement("script"),e.type="text/javascript",e.async=!0,e.src=t,s=document.getElementsByTagName("script")[0],s.parentNode.insertBefore(e,s)}(("https:"==document.location.protocol?"https://":"http://")+"bbp.salesmanago.pl/dynamic/"+_smid+"/popups.js");!function(t,e,s,n,a){t.SalesmanagoObject=e,t[e]=t[e]||function(){(t[e].q=t[e].q||[]).push(arguments)},n=document.createElement("script"),n.type="text/javascript",n.async=!0,n.src=s,a=document.getElementsByTagName("script")[0],a.parentNode.insertBefore(n,a)}(window,"sm",("https:"==document.location.protocol?"https://":"http://")+"bbp.salesmanago.pl/static/sm.js");sm('webPush', ['c9063cf4-5b45-481b-89fe-7a520bc38bcc', '87600']);</script>
<script type="application/ld+json">{"@context": "https://schema.org", "@type": "WebPage", "mainEntity": {"@type": "NewsArticle", "name": "Sektor technologiczny czekaj\u0105 trudne chwile", "headline": "Sektor technologiczny czekaj\u0105 trudne chwile", "description": "Skutki spowolnienia gospodarki dotykaj\u0105 nawet takie sp\u00f3\u0142ki, jak Amazon i Apple. Wszystko wskazuje na to, \u017ce wyniki za II kwarta\u0142 2022 r. oka\u017c\u0105 si\u0119 dalekie od tych, to jakich inwestorzy si\u0119 przyzwyczaili.", "author": [{"@type": "Person", "name": "Miko\u0142aj \u015ami\u0142owski", "email": "m.smilowski@pb.pl", "url": "https://www.pb.pl/autor/mikolaj-smilowski/"}], "datePublished": "2022-07-26T18:00:00Z", "dateModified": "2022-07-26T18:00:00Z", "mainEntityOfPage": {"@type": "WebPage", "@id": "https://www.pb.pl/sektor-technologiczny-czekaja-trudne-chwile-1156828"}, "articleSection": "", "articleBody": "Wi\u0119kszo\u015b\u0107 ameryka\u0144skich sp\u00f3\u0142ek technologicznych opublikuje naj\u015bwie\u017csze dane finansowe w ci\u0105gu nast\u0119pnych dw\u00f3ch tygodni. Inwestorzy ju\u017c teraz wyceniaj\u0105 z\u0142e wie\u015bci - oczekuj\u0105 najs\u0142abszego przyrostu przychod\u00f3w Amazona od dw\u00f3ch dekad, spadku popytu na p\u00f3\u0142przewodniki od AMD i Intela oraz mniejszego zapotrzebowania na us\u0142ugi Ubera czy Lyfta. Najwi\u0119kszym ciosem ma by\u0107 jednak spadek zysk\u00f3w z reklam, kt\u00f3ry w zesz\u0142ym tygodniu dobi\u0142 notowania Snapa i Twittera, a wkr\u00f3tce zapewne utnie wycen\u0119 Mety, w\u0142a\u015bciciela Facebooka.", "publisher": {"@type": "Organization", "name": "Puls Biznesu", "logo": {"@type": "ImageObject", "name": "Logo Pulsu Biznesu", "author": "", "datePublished": "1997-01-14", "url": "https://www.pb.pl/static/img/puls-biznesu.png"}}, "image": {"@type": "ImageObject", "name": "Sektor technologiczny czekaj\u0105 trudne chwile", "author": "", "datePublished": "2022-07-26T18:00:00Z", "url": "https://images.pb.pl/filtered/a2ef19e6-37a3-43e5-9411-35f2ee96cf43/90347d97-13c7-5d21-8cad-9823627b58dc_w_1045.jpg"}, "isAccessibleForFree": "False", "hasPart": {"@type": "WebPageElement", "isAccessibleForFree": "False", "cssSelector": ".paywall"}}, "breadcrumb": {"@type": "BreadcrumbList", "itemListElement": [{"@type": "ListItem", "position": 1, "item": {"@type": "Website", "@id": "https://www.pb.pl", "name": "Puls Biznesu"}, "image": {"@type": "ImageObject", "name": "Logo Pulsu Biznesu", "author": "", "datePublished": "1997-01-14", "url": "https://www.pb.pl/static/img/puls-biznesu.png"}}, {"@type": "ListItem", "position": 2, "item": {"@type": "Webpage", "@id": "https://www.pb.pl/kategoria/akcje/", "name": "Akcje"}}, {"@type": "ListItem", "position": 3, "item": {"@type": "Webpage", "@id": "https://www.pb.pl/sektor-technologiczny-czekaja-trudne-chwile-1156828", "name": "Sektor technologiczny czekaj\u0105 trudne chwile"}}]}}</script>
 
    <script src="https://cdn.cxense.com/cx.cce.js"></script>
<script>
(function(w,d,t,u,n,a,m,l,s){
w[n]=w[n]||function(){(w[n].q=w[n].q||[]).push(arguments);};
a=d.createElement(t);
m=d.getElementsByTagName(t)[0];
a.async=1;
a.src=u;
m.parentNode.insertBefore(a,m);
})(window,document,'script','https://bart.bonnieraws.dergan.net/bart.js','_BART');
</script>

<script>
if (npb && npb.client_data.user_id) {
    var user_id = npb.client_data.user_id;
} else {
    var user_id = null;
}
if (user_id) {
    _BART("init", {
        groupId: "PBPL",
        userId: "" + user_id
    });

    var bart_data = { url: window.location.href };
    _BART("push", "freq", bart_data);


    var article_id = 1156828;
    var title = "Sektor technologiczny czekają trudne chwile";

    if (article_id) {
        var art_data = {
            userId: "" + user_id,
            articleId: "" + article_id,
            marker: "article_read",
            title: "" + title,
            url: "https://www.pb.pl/sektor-technologiczny-czekaja-trudne-chwile-1156828",
            article_param1: "Mikołaj Śmiłowski",
            article_param2: "",
            article_param3: "",
            article_param4: ""
        };
        _BART("push", "event", art_data);
    }

}


</script>
<script async src="//cmp.optad360.io/items/c11910a0-32e7-4d28-b75b-bea2dc39b4b5.min.js"></script>
</head>
<body>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PTPFH5&author=Miko%C5%82aj+%C5%9Ami%C5%82owski&section=Puls+Inwestora&category=Makroekonomia%7CAkcje&newsId=1156828&publicationDate=2022-07-26&publication_status=closed"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><noscript>
<img style="display: none !important;" src="//www.pb.pl/static/img/puls-biznesu.png" width="500" height="400" loading="lazy">
</noscript>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var gemius_identifier = 'zZ2Q.W_w283rdfPLwD9e38U1P6O1WeMmKa6GwbKOVjr.z7';
var gemius_extraparameters = new Array('article_id=1156828', 'publication_date=2022-07-26', 'publication_status=closed', 'page_type=article', 'gate_status=no_access');
// lines below shouldn't be edited
function gemius_pending(i) { window[i] = window[i] || function() {var x = window[i+'_pdata'] = window[i+'_pdata'] || []; x[x.length]=arguments;};};gemius_pending('gemius_hit'); gemius_pending('gemius_event'); gemius_pending('pp_gemius_hit'); gemius_pending('pp_gemius_event');(function(d,t) {try {var gt=d.createElement(t),s=d.getElementsByTagName(t)[0],l='http'+((location.protocol=='https:')?'s':''); gt.setAttribute('async','async');gt.setAttribute('defer','defer'); gt.src=l+'://pro.hit.gemius.pl/gemius.js'; s.parentNode.insertBefore(gt,s);} catch (e) {}})(document,'script');
//--><!]]>
</script>
<!-- Cxense script begin -->
<script type="text/javascript">
  var cX = window.cX = window.cX || {}; cX.callQueue = cX.callQueue || [];
  // Compat mode, 3s delay
  cX.options = cX.options || { compat: { c1x: { wait: 3000 } } };
  cX.CCE = cX.CCE || {}; cX.CCE.callQueue = cX.CCE.callQueue || [];
  cX.callQueue.push(['setSiteId','1128463045459712937']);
  cX.CCE.callQueue.push(['sendPageViewEvent']);
</script>
<!-- Cxense script end -->
    <div id="npb-su">
<header class="npb-mh npb-mh-ap">
    <div class="npb-g-s-f npb-g-s-0 npb-g-s-adv">
        <div class="npb-g-r">
        </div>
    </div>
    <div class="mobile-view free-account">
<div class="npb-subscription-bar">
    <div class="npb-subscription-bar__content">
        <span>CZYTAJ BEZ OGRANICZEŃ</span>
        <a class="buySubscriptionBtn" href="/subskrypcja/">KUP SUBSKRYPCJĘ</a>
    </div>
</div>    </div> 
    <div class="mobile-view npb-sponsor__topbar"></div>  
    <div class="npb-mh-t npb-g-c-hidden-down">
        <div class="npb-g-s">
            <div class="npb-g-r">

        <div class="npb-g-c npb-g-c-12">
            <div class="npb-g-r">
                <div class="npb-g-c npb-g-c-12 npb-g-ipr npb-sponsor__fix" id="LinkArea:User" data-vr-zone="User">
                    <div class="npb-sponsor__user-menu"></div>
<ul class="npb-nav npb-mh-nav-0 npb-login-toggle npb-g-c-hidden-up">
    
    <li>
        <a href="/konto/schowek/">
            Witaj,
            <u id="npb-nav-user-name">Czytelniku</u>
        </a>
    </li>
    <li>
        <a class="npb-btn npb-btn-safe" href="/konto/schowek/">
            <span class="npb-btn-l">Schowek
                <span id="npb-nav-stash-counter" class="npb-stash-counter" data-stash-counter="0"></span>
            </span>
            <span class="npb-l-i npb-l-i-star-f"></span>
        </a>
    </li>
    <li>
        <a class="npb-js-next" href="/konto/wyloguj/">Wyloguj się</a>
    </li>
</ul>
<ul class="npb-nav npb-mh-nav-0 npb-login-toggle">
    <li>
        <!-- <a class="npb-btn npb-dd-toggle npb-nav-dd-um-toggle" href="/konto/logowanie/" data-target="#npb-nav-dd-um">Zaloguj <span class="npb-l-i npb-l-i-close"></span></a> -->
        <div class="npb-btn pianoLogin">Zaloguj</div>
        <a class="npb-btn pianoName" href="/konto/schowek" style="display: none;"></a>
        <div class="npb-btn pianoLogout" style="display: none">Wyloguj</div>
    </li>
</ul>                </div>
            </div>
        </div>
            </div>  
        </div>
    </div>

	<div class="npb-mh-m">
		<div class="npb-g-s">
			<div class="npb-g-r npb-g-r-c-mp-0-down">
				<div class="npb-g-c npb-g-c-12">
					<nav class="navbar npb-nav-mm">
                        <img class="npb-nav-logo-birthday" src="/static/img/pb-logo-25.png" alt="Puls Biznesu 25 lat">
                        <div id="LinkArea:Logotype">
                            <a class="npb-nav-logo" title="Puls Biznesu" href="/">
                                    <picture>
                                        <source srcset="/static/img/pb-logo-mc.png 1x, /static/img/pb-logo-mc-2x.png 2x" type="image/png" media="(min-width: 980px)">
                                        <source srcset="/static/img/pb-logo.png 1x, /static/img/pb-logo-2x.png 2x" type="image/png">
                                        <img src="/static/img/pb-logo.png" alt="Puls Biznesu">
                                    </picture>
                                </a>
                        </div>

    <ul class="npb-nav npb-mh-nav-2 main-header" role="menu" id="LinkArea:NavBar" data-vr-zone="NavBar">
            <li>
                <a href="/puls-dnia/live/">
                        Z ostatniej chwili
                </a>
            </li>
            <li>
                <a target="_blank" href="https://notowania.pb.pl">
                        Notowania
                </a>
            </li>
            <li>
                <a href="https://www.pb.pl/newslettery?utm_source=pb.pl&amp;utm_medium=belka&amp;utm_campaign=newslettery">
                        Newslettery
                </a>
            </li>
            <li>
                <a href="https://www.pb.pl/wydanie">
                        Dzisiejsze wydanie
                </a>
            </li>
    </ul>

<div id="npb-nav-dd-um" class="npb-dd npb-nav-dd-um" role="navigation">
    <div class="npb-g-r npb-g-r-mp-0">
        <div class="npb-g-c npb-g-c-12">
<ul class="npb-nav npb-mh-nav-3 npb-login-toggle npb-g-mc-hidden-up" role="menu">
    <li>
        <a href="/konto/schowek/" class="pianoName">
            Witaj,
            <u id="npb-mnav-user-name">Czytelniku</u>
        </a>
    </li>
    <li>
        <a class="npb-btn npb-btn-safe" href="/konto/schowek/">
            <span class="npb-btn-l">Schowek
                <span id="npb-mnav-stash-counter" class="npb-stash-counter" data-stash-counter="0"></span>
            </span>
            <span class="npb-l-i npb-l-i-star-f"></span>
        </a>
    </li>
    <li>
        <a href="#" class="pianoLogout">Wyloguj się</a>
    </li>
</ul>        </div>
    </div>
</div>                        
<div id="npb-nav-dd-mm" class="npb-dd npb-nav-dd-mm" role="navigation">
    <div class="npb-g-r npb-g-r-mp-0 npb-g-o-c">
        <div class="npb-g-c npb-g-c-12 npb-g-mc-7d2 npb-g-o-1">

            <ul class="npb-nav npb-mh-nav-3" role="menu">
                            <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_1">
                <a href="/puls-dnia/live/">
                        Z ostatniej chwili
                </a>
            </li>

                    <li class="npb-nav-cc" id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_2">
        <a href="/puls-firmy/">
            Puls Firmy
        </a>
        <div class="npb-btn-g">
            <button class="npb-btn npb-cc-toggle npb-nav-cc-sm-toggle" type="button" data-target="#npb-nav-cc-sm-0">
                <span class="sr-only">Rozwiń/Zwiń submenu</span>
                <span class="npb-l-i npb-l-i-arrow-t"></span>
                <span class="npb-l-i npb-l-i-arrow-d"></span>
            </button>
        </div>
        <div id="npb-nav-cc-sm-0" class="npb-cc npb-nav-cc-sm" aria-expanded="true">
            <ul class="npb-nav npb-nav-sm" role="menu">
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_2_1">
                        <a href="https://www.pb.pl/gazele/">
                            Gazele Biznesu
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_2_2">
                        <a href="/puls-firmy/fundusze-unijne/">
                            Fundusze unijne
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_2_3">
                        <a href="/puls-firmy/finansowanie/">
                            Finansowanie
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_2_4">
                        <a href="https://lexbiznes.pb.pl">
                            Prawo dla firm
                        </a>
                    </li>
            </ul>
        </div>
    </li>

                    <li class="npb-nav-cc" id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_3">
        <a href="/puls-innowacji/">
            Puls Innowacji
        </a>
        <div class="npb-btn-g">
            <button class="npb-btn npb-cc-toggle npb-nav-cc-sm-toggle" type="button" data-target="#npb-nav-cc-sm-1">
                <span class="sr-only">Rozwiń/Zwiń submenu</span>
                <span class="npb-l-i npb-l-i-arrow-t"></span>
                <span class="npb-l-i npb-l-i-arrow-d"></span>
            </button>
        </div>
        <div id="npb-nav-cc-sm-1" class="npb-cc npb-nav-cc-sm" aria-expanded="true">
            <ul class="npb-nav npb-nav-sm" role="menu">
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_3_1">
                        <a href="/puls-innowacji/start-upy/">
                            Start-upy
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_3_2">
                        <a href="/puls-innowacji/it-internet/">
                            IT&amp;Internet
                        </a>
                    </li>
            </ul>
        </div>
    </li>

            </ul>

            <ul class="npb-nav npb-mh-nav-3" role="menu">
                    <li class="npb-nav-cc" id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_4">
        <a href="/puls-inwestora/">
            Puls Inwestora
        </a>
        <div class="npb-btn-g">
            <button class="npb-btn npb-cc-toggle npb-nav-cc-sm-toggle" type="button" data-target="#npb-nav-cc-sm-2">
                <span class="sr-only">Rozwiń/Zwiń submenu</span>
                <span class="npb-l-i npb-l-i-arrow-t"></span>
                <span class="npb-l-i npb-l-i-arrow-d"></span>
            </button>
        </div>
        <div id="npb-nav-cc-sm-2" class="npb-cc npb-nav-cc-sm" aria-expanded="true">
            <ul class="npb-nav npb-nav-sm" role="menu">
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_4_1">
                        <a href="/puls-inwestora/komentarze/">
                            GPW
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_4_2">
                        <a href="/puls-inwestora/waluty/">
                            Waluty
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_4_3">
                        <a href="/puls-inwestora/surowce/">
                            Surowce
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_4_4">
                        <a href="https://360.pb.pl/akcjainwestor">
                            Akcja Inwestor
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_4_5">
                        <a href="/puls-inwestora/spolka-roku/">
                            Spółka roku
                        </a>
                    </li>
            </ul>
        </div>
    </li>

                    <li class="npb-nav-cc" id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_5">
        <a href="https://notowania.pb.pl">
            Notowania
        </a>
        <div class="npb-btn-g">
            <button class="npb-btn npb-cc-toggle npb-nav-cc-sm-toggle" type="button" data-target="#npb-nav-cc-sm-3">
                <span class="sr-only">Rozwiń/Zwiń submenu</span>
                <span class="npb-l-i npb-l-i-arrow-t"></span>
                <span class="npb-l-i npb-l-i-arrow-d"></span>
            </button>
        </div>
        <div id="npb-nav-cc-sm-3" class="npb-cc npb-nav-cc-sm" aria-expanded="true">
            <ul class="npb-nav npb-nav-sm" role="menu">
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_5_1">
                        <a href="https://notowania.pb.pl/stocktable/UTP000,Wallets">
                            Indeksy
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_5_2">
                        <a href="https://notowania.pb.pl/stocktable/GPWAKCJE">
                            Spółki
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_5_3">
                        <a href="https://notowania.pb.pl/currencies/">
                            Waluty
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_5_4">
                        <a href="https://notowania.pb.pl/funds/">
                            Fundusze
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_5_5">
                        <a href="https://notowania.pb.pl/foreign/">
                            Zagranica
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_5_6">
                        <a href="https://notowania.pb.pl/commodities/">
                            Surowce
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_5_7">
                        <a href="https://notowania.pb.pl/makro">
                            Wskaźniki makro
                        </a>
                    </li>
                    <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_5_8">
                        <a href="https://nieruchomosci.pb.pl/ceny-mieszkan">
                            Ceny nieruchomości
                        </a>
                    </li>
            </ul>
        </div>
    </li>

            </ul>

            <ul class="npb-nav npb-mh-nav-3" role="menu">

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_6">
                <a href="/newslettery">
                        Newslettery
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_7">
                <a href="/dosluchania/">
                        PB do słuchania
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_8">
                <a href="/nieruchomosci/">
                        Nieruchomości
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_9">
                <a href="/motoryzacja/">
                        Motoryzacja
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_10">
                <a href="/kariera/">
                        Kariera
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_11">
                <a href="/kategoria/transport-i-logistyka/">
                        Transport i logistyka
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_12">
                <a href="/pogodzinach">
                        Po Godzinach
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_13">
                <a href="https://www.pb.pl/konferencje/">
                        Konferencje i eventy
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_14">
                <a href="https://pulsmedycyny.pl">
                        <span class="npb-t-c-w">Puls</span> Medycyny
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_15">
                <a href="/mlody-biznes/">
                        Młody biznes
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_16">
                <a href="https://www.pb.pl/wideo/">
                        <span class="npb-t-c-w">Puls</span>Biznesu.tv
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_17">
                <a href="/subskrypcja/licencja/">
                        Licencja
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_18">
                <a href="/faq/">
                        FAQ
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_19">
                <a href="/konto/e-wydania/">
                        e-Wydanie
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_20">
                <a href="https://360.pb.pl/aplikacja">
                        Aplikacja mobilna
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_21">
                <a href="/kategoria/bankowosc/">
                        Banki
                </a>
            </li>

            </ul>

        </div>

        <div class="npb-g-c npb-g-c-12 npb-g-mc-4d8 npb-g-o-3">
            <ul class="npb-nav npb-mh-nav-4" role="menu">
                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_22">
                <a href="/kategoria/przemysl-rolno-spozywczy/">
                        Przemysł rolno-spożywczy
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_23">
                <a href="/kategoria/przemysl-chemiczny/">
                        Przemysł chemiczny
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_24">
                <a href="/topic/ekologia/">
                        Ekologia
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_25">
                <a href="/kategoria/energetyka-i-gornictwo/">
                        Energetyka i górnictwo
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_26">
                <a href="/kategoria/farmacja/">
                        Farmacja
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_27">
                <a href="/kategoria/handel/">
                        Handel
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_28">
                <a href="/kategoria/przemysl-ciezki/">
                        Przemysł ciężki
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_29">
                <a href="/kategoria/media-marketing-pr/">
                        Media, Marketing, PR
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_30">
                <a href="/kategoria/ochrona-zdrowia/">
                        Ochrona zdrowia
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_31">
                <a href="/topic/wojsko/">
                        Obronność
                </a>
            </li>

            </ul>

            <ul class="npb-nav npb-mh-nav-4" role="menu">
                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_32">
                <a href="/kategoria/podatki/">
                        Podatki
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_33">
                <a href="/kategoria/polityka/">
                        Polityka
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_34">
                <a href="/kategoria/prawo/">
                        Prawo
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_35">
                <a href="/kategoria/samorzady/">
                        Samorządy
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_36">
                <a href="/topic/stocznie/">
                        Stocznie
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_37">
                <a href="/kategoria/telekomunikacja/">
                        Telekomunikacja
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_38">
                <a href="/kategoria/ubezpieczenia/">
                        Ubezpieczenia
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_39">
                <a href="/kategoria/komunikaty/">
                        Komunikaty
                </a>
            </li>

                                <li id="LinkArea:NavSubHam" data-vr-zone="NavSubHam_40">
                <a href="https://pb.pl/story/polski-lad">
                        Polski Ład
                </a>
            </li>

            </ul>
        </div>

<div class="ns-ham-promo">
    <div class="ns-ham-promo__body">
        <div class="ns-ham-promo__title">Subskrybuj „PB”</div>
        <div class="ns-ham-promo__subtitle">i przekształcaj zdobytą wiedzę w&nbsp;biznesowy sukces.</div>
        <div>Już od 5 zł za miesiąc!</div>
        <a href="/subskrypcja/" class="ns-ham-promo__btn">Dołącz do społeczności PB</a>
    </div>
</div>        
    </div>
</div>

<div id="npb-nav-dd-s" class="npb-dd npb-nav-dd-s">
    <div class="npb-g-r npb-g-r-mp-0">
        <div class="npb-g-c npb-g-c-12 npb-g-mc-6 npb-g-pr">
            <form id="search-bar-form" class="npb-form npb-iform npb-form-k-13 jqv-form-no-msg" role="search" autocomplete="off" method="get" action="/wyszukiwarka">
                <div class="npb-input-g">
                    <input class="npb-form-ctrl" id="q" name="q" placeholder="wpisz kategorie, spółkę, nazwisko..." required type="text" value="">
                    <span class="npb-input-g-btn">
                        <button class="npb-btn" type="submit">
                            <span class="npb-l-i npb-l-i-magnifier"></span>
                        </button>
                    </span>
                </div>
                <input type="hidden" name="sort_type" value="1">
                <input type="hidden" name="page" value="1">
             </form>
        </div>
    </div>
</div>                        
						<div class="npb-btn-g-v npb-g-pr">
                			<button class="npb-btn npb-dd-toggle npb-nav-dd-mm-toggle" type="button" data-target="#npb-nav-dd-mm" id="LinkArea:NavMainHam" data-vr-zone="NavMainHam">
                    			<span class="sr-only">Rozwiń/Zwiń menu</span>
                    			<span class="npb-l-i-bar npb-l-i-bar-1"></span>
                    			<span class="npb-l-i-bar npb-l-i-bar-2"></span>
                    			<span class="npb-l-i-bar npb-l-i-bar-3"></span>
                			</button>

                			<button class="npb-btn npb-dd-toggle npb-nav-dd-s-toggle" type="button" data-target="#npb-nav-dd-s">
                    			<span class="sr-only">Rozwiń/Zwiń wyszukiwarkę</span>
                    			<span class="npb-l-i npb-l-i-magnifier"></span>

                                <span class="npb-dd-toggle-close">
                                    <span class="npb-l-i-bar npb-l-i-bar-1"></span>
                                    <span class="npb-l-i-bar npb-l-i-bar-2"></span>
                                    <span class="npb-l-i-bar npb-l-i-bar-3"></span>
                                </span>
                            </button>

                            <a id="npb-btn-mobile-login" href="/konto/logowanie/" class="npb-btn npb-nav-um-login npb-g-mc-hidden-up">
                                <span class="npb-l-i npb-l-i-user"></span>
                            </a>

                            <button id="npb-btn-mobile-user-menu" class="npb-btn npb-dd-toggle npb-nav-dd-um-toggle npb-g-mc-hidden-up" type="button" data-target="#npb-nav-dd-um" style="display: none;">
                    			<span class="sr-only">Rozwiń/Zwiń menu Użytkownika</span>
                    			<span class="npb-l-i npb-l-i-user"></span>

                			    <span class="npb-dd-toggle-close">
                                    <span class="npb-l-i-bar npb-l-i-bar-1"></span>
                                    <span class="npb-l-i-bar npb-l-i-bar-2"></span>
                                    <span class="npb-l-i-bar npb-l-i-bar-3"></span>
                                </span>
                            </button>
                			
                		</div>
                    </nav>
				</div>
			</div>
		</div>
	</div>
</header>
<div id="npb-mw" class="npb-mw npb-mw-ap">

    <div id="npb-sas-1" class="npb-g-s-f npb-g-s-1">
        <div class="npb-g-r">

            <div class="npb-g-s">
                <div class="npb-g-r">
                    <div class="npb-g-c npb-g-c-12">
                        <div class="npb-g-r npb-g-o-c">

                            <div class="ns-banner-up npb-g-o-1 -gate "></div>

<div id="ArticleGate" data-access="0" class="npb-g-o-2" >
<article class="npb-a ns-gate-article">

    <header class="npb-a-h ns-gate-article__header">
        <h1>
            <p class="npb-a-l">Sektor technologiczny czekają trudne chwile</p>
        </h1>
<div class="npb-g-r">
    <div class="npb-g-c npb-g-c-12 npb-g-mc-t-up npb-a-h-d ns-gate-article__author">
                    <div class="npb-g-r npb-g-t-r npb-g-o-c">
                <div class="npb-g-t-c-b npb-a-h-d-author npb-g-o-2">
                    <div class="npb-g-t-c-l npb-author-info">
                        <ul>
                            <li class="npb-a-h-d-author-name">
                                    <a href="/autor/mikolaj-smilowski/">
                                        Mikołaj Śmiłowski
                                    </a>
                            </li>
                        </ul>
                    </div>
                    <div class="npb-g-t-c-b npb-a-h-d-author-btn">
                            <div class="npb-btn-g">
                                <a class="npb-btn npb-btn-author ns-author-link" href="/autor/mikolaj-smilowski/"><span>zobacz wszystkie moje teksty</span></a>
                            </div>
                    </div>
                </div>

                    <div class="npb-g-t-c-b npb-a-h-d-date npb-g-o-1">
                        <span class="npb-a-h-d-pub-date">
                            opublikowano: dzisiaj, 26-07-2022, 20:00
                        </span>
                    </div>
            </div>


    </div>
</div>    </header>
    <div data-io-article-url="https://www.pb.pl/sektor-technologiczny-czekaja-trudne-chwile-1156828" class="ns-gate-article__content">

<div class="ns-player-placeholder">
    <img class="ns-player-placeholder__icon-play" src="/static/img/ns/icons/play.png" alt="Play icon" loading="lazy">
    <div class="ns-player-placeholder__text">Posłuchaj</div>
    <div class="ns-player-placeholder__progress-bar"></div>
    <img class="ns-player-placeholder__icon-speaker" src="/static/img/ns/icons/speaker.png" alt="Speaker icon" loading="lazy">
    <div class="ns-player-placeholder__tooltip">
        <img class="ns-player-placeholder__tooltip-icon-close" src="/static/img/ns/icons/icon-close.svg" alt="Close icon" loading="lazy">
        <div class="ns-player-placeholder__tooltip-title">Zostań subskrybentem</div>
        <div class="ns-player-placeholder__tooltip-description">i słuchaj tego oraz wielu innych artykułów w pb.pl</div>
        <div class="ns-player-placeholder__tooltip-footer">
            <a class="ns-player-placeholder__tooltip-link -login pianoLogin" href="#">Logowanie</a>
            <a class="ns-player-placeholder__tooltip-link -subscription" href="https://www.pb.pl/subskrypcja">Subskrypcja</a>
        </div>
    </div>
</div>

            <p class="npb-a-l">Skutki spowolnienia gospodarki dotykają nawet takie spółki, jak Amazon i&nbsp;Apple. Wszystko wskazuje na&nbsp;to, że&nbsp;wyniki za&nbsp;II kwartał 2022 r. okażą się dalekie od&nbsp;tych, to&nbsp;jakich inwestorzy się przyzwyczaili.</p>

            <p class="summary"><p>Przeczytaj artykuł i dowiedz się:</p><ul><li>jakie czynniki wpłyną na wyniki spółek technologicznych</li><li>czemu są one głównym kandydatem do spadków giełdowych</li><li>co może poprawić ich sytuacje</li><li>jaki wpływ będzie miał na nie Fed</li></ul></p>

    </div>
</article>
    <div class="ns-gate io-subscription-block ">
<div class="ns-gate-info">
    <img class="ns-gate-info__icon" alt="book icon" src="/static/img/ns/icons/icon-book.svg" width="38" height="36" loading="lazy">
    <div class="ns-gate-info__text -closed">Artykuł dostępny tylko dla naszych subskrybentów</div>
</div>
<div class="ns-gate-headline">
    <h1 class="ns-gate-headline__title">Zyskaj wiedzę, oszczędź czas</h1>
    <span class="ns-gate-headline__subtitle">Informacja jest na wagę złota. Piszemy tylko o biznesie</span>
    <img class="ns-gate-headline__img" src="/static/img/ns/sub-mobile.png" alt="Subskrypcja PB" width="652" height="410" loading="lazy">
</div><div class="ns-gate-body">
<div class="ns-gate-tile -birthday" id="GateOfferForNew">
    <div class="ns-gate-tile__content">
        <img class="ns-gate-tile__img -new" src="/static/img/ns/icons/icon-poznaj.svg" alt="Premium Offer" width="72" height="48" loading="lazy">
        <div class="ns-gate-tile__name"><b>Poznaj „PB”</b></div>
        <!--
        <div class="ns-gate-tile__price">
            <span class="-lt">79&nbsp;zł</span>
            <span class="-r">7,90&nbsp;zł</span>
            <span>/&nbsp;miesiąc</span>
        </div>
        <div class="ns-gate-tile__info">przez pierwsze <span class="-r">3 miesiące</span></div>
        <div class="ns-gate-tile__text">
            <span>Chcesz nas lepiej poznać?</span>
            <span>Wypróbuj dostęp do pb.pl przez trzy&nbsp;miesiące w&nbsp;promocyjnej&nbsp;cenie!</span>
        </div>
        <a href="/subskrypcja/oferta/npb-recurring-trial-01m" class="ns-gate-tile__btn promo-click-btn io-subscription-button">WYBIERZ</a>
        -->
        <div class="ns-gate-tile__price">
            <span class="-lt">79&nbsp;zł</span>
            <span class="-r">5&nbsp;zł</span>
            <span class="-period">/&nbsp;miesiąc</span>
        </div>
        <div class="ns-gate-tile__info">przez pierwsze <span class="-r">dwa miesiące</span><br>później cena wynosi 79&nbsp;zł miesięcznie</div>
        <div class="ns-gate-tile__text">
            <span>Cały artykuł mogą przeczytać tylko nasi subskrybenci.</span>
            <span>Tylko teraz dostęp w promocyjnej cenie.</span>
        </div>
        <a href="/subskrypcja/oferta/npb-recurring-basic-5-79-01m" class="ns-gate-tile__btn promo-click-btn io-subscription-button">WYBIERZ</a>
    </div>
</div>

<div class="ns-gate-tile -birthday" id="GateOfferForOld" style="display: none;">
    <div class="ns-gate-tile__content">
        <img class="ns-gate-tile__img -new" src="/static/img/ns/icons/icon-poznaj.svg" alt="Premium Offer" width="72" height="48" loading="lazy">
        <div class="ns-gate-tile__name"><b>Poznaj „PB”</b></div>
        <div class="ns-gate-tile__price">
            <span class="-lt">79&nbsp;zł</span>
            <span class="-r">10&nbsp;zł</span>
            <span>/&nbsp;miesiąc</span>
        </div>
        <div class="ns-gate-tile__info">przez pierwsze <span class="-r">dwa miesiące</span><br>później cena wynosi 79&nbsp;zł miesięcznie</div>
        <div class="ns-gate-tile__text">
            <span>Od jakiegoś czasu nie masz pełnego dostępu do publikowanych treści na pb.pl. Nie może Cię ominąć żaden kolejny news.</span>
            <spna>Wróć do świata biznesu i czytaj „PB” już dzisiaj.</span>
        </div>
        <a href="/subskrypcja/oferta/npb-recurring-basic-10-79-01m" class="ns-gate-tile__btn promo-click-btn io-subscription-button">WYBIERZ</a>
    </div>
</div><div class="ns-gate-tile">
    <div class="ns-gate-tile__content">
        <div class="ns-gate-tile__label">Rabat 30%</div> 
        <img class="ns-gate-tile__img -basic" src="/static/img/ns/icons/icon-basic.svg" alt="Basic Offer" width="85" height="47" loading="lazy">
        <div class="ns-gate-tile__name"><b>„PB" NA 12 MIESIĘCY</b></div>
        <div class="ns-gate-tile__price">
            <span class="-r">663&nbsp;zł</span>
            <span>/&nbsp;rok</span>
        </div>
        <div class="ns-gate-tile__info">Skorzystaj z 30% rabatu</div>
        <div class="ns-gate-tile__text">
            <span>Zapłać raz i czytaj nasze treści bez&nbsp;ograniczeń przez&nbsp;cały&nbsp;rok.</span>
            <span>Zaoszczędzisz 285 zł.</span>
        </div>
        <a href="/subskrypcja/oferta/npb-basic-12m" class="ns-gate-tile__btn promo-click-btn io-subscription-button">WYBIERZ</a>
    </div>
</div></div>
    </div>
</div>

                            <div class="npb-g-c npb-g-c-12 npb-g-o-4">
                            </div>

                            <div class="npb-g-c npb-g-c-12 npb-clearfix npb-g-c-hidden-down"></div>
    <div id="most_important_original" class="npb-g-c npb-g-c-12 npb-g-mc-8 npb-g-lc-7 npb-g-lc-push-2 npb-g-o-6">
        <div id="content_reco_1" class="npb-g-r">
            <div class="npb-g-c npb-g-c-12">
                <section class="npb-b npb-b-s-3 npb-b-al" style="margin-bottom: 20px;">
                    <header class="npb-b-h" style="border-bottom: 6px solid #000;" id="most_important">
                        <h4>Być może zainteresuje Cię też:</h4>
                    </header>
                    <div class="npb-g-r">
                        <div class="npb-g-c npb-g-c-12">
                            <div class="npb-a-box npb-a-box-2">
                                    

    <a href="/wszystko-o-rynku-najmu-i-sprzedazy-mieszkan-1156836">
        <div class="npb-g-c-t-up">
            <div class="npb-g-t-r">
                <div class="npb-g-t-c">
                    <div class="npb-g-t-c-l">
                        <picture>
                            <source srcset="https://images.pb.pl/filtered/028f5fde-0924-4fd3-af02-32addab28187/afd2d3a4-4d73-5ac7-8296-eb0a41dc16ce_mc_l.jpg" type="image/jpeg" media="(min-width: 980px)">
                            <source srcset="https://images.pb.pl/filtered/028f5fde-0924-4fd3-af02-32addab28187/afd2d3a4-4d73-5ac7-8296-eb0a41dc16ce_xc_l.jpg" type="image/jpeg">
                            <img src="https://images.pb.pl/filtered/028f5fde-0924-4fd3-af02-32addab28187/afd2d3a4-4d73-5ac7-8296-eb0a41dc16ce_mc_l.jpg" width="192" height="120" loading="lazy" alt="Wszystko o rynku najmu i sprzedaży mieszkań">
                        </picture>
                        <span class="npb-l-bg-grad"></span>
                    </div>
                    <div class="npb-g-t-c-b">
                            <h2>
                                <span class="excerpt">Wszystko o&nbsp;rynku najmu i&nbsp;sprzedaży mieszkań</span>
                            </h2>
                            <p class="npb-a-l npb-g-c-hidden-down">
                                <span class="excerpt">O ile rynek sprzedaży mieszkań schłodził się w&nbsp;wyniku podwyżek stop procentowych, o&nbsp;tyle rynek najmu rozgrzewają uchodźcy z&nbsp;Ukrainy. Oferty szybko znikają z&nbsp;serwisów.</span>
                            </p>
                    </div>
                </div>
            </div>
        </div>
    </a>

                            </div>
                            <div class="npb-a-box npb-a-box-2">
                                    

    <a href="/budimex-ma-recepte-na-przetargowe-spowolnienie-1156831">
        <div class="npb-g-c-t-up">
            <div class="npb-g-t-r">
                <div class="npb-g-t-c">
                    <div class="npb-g-t-c-l">
                        <picture>
                            <source srcset="https://images.pb.pl/filtered/d9e16a1d-2c6c-4fdc-bff7-bfbdb5186a02/ee7d4196-2bb8-5995-a768-7aad206b99f3_mc_l.jpg" type="image/jpeg" media="(min-width: 980px)">
                            <source srcset="https://images.pb.pl/filtered/d9e16a1d-2c6c-4fdc-bff7-bfbdb5186a02/ee7d4196-2bb8-5995-a768-7aad206b99f3_xc_l.jpg" type="image/jpeg">
                            <img src="https://images.pb.pl/filtered/d9e16a1d-2c6c-4fdc-bff7-bfbdb5186a02/ee7d4196-2bb8-5995-a768-7aad206b99f3_mc_l.jpg" width="192" height="120" loading="lazy" alt="Budimex ma receptę na przetargowe spowolnienie">
                        </picture>
                        <span class="npb-l-bg-grad"></span>
                    </div>
                    <div class="npb-g-t-c-b">
                            <h2>
                                <span class="excerpt">Budimex ma&nbsp;receptę na&nbsp;przetargowe spowolnienie</span>
                            </h2>
                            <p class="npb-a-l npb-g-c-hidden-down">
                                <span class="excerpt">Wartość publicznych przetargów infrastrukturalnych w&nbsp;Polsce spadła w&nbsp;trzy lata z&nbsp;35 do&nbsp;26 mld zł, a&nbsp;prywatnych będzie mniej o&nbsp;połowę. Grupa realizuje więc plan ekspansji na&nbsp;nowych rynkach.</span>
                            </p>
                    </div>
                </div>
            </div>
        </div>
    </a>

                            </div>
                            <div class="npb-a-box npb-a-box-2">
                                    

    <a href="/jak-obnizyc-podatki-1156843">
        <div class="npb-g-c-t-up">
            <div class="npb-g-t-r">
                <div class="npb-g-t-c">
                    <div class="npb-g-t-c-l">
                        <picture>
                            <source srcset="https://images.pb.pl/filtered/329a1626-9ae6-4915-aa2d-497314860efa/9210aacb-0e1a-52ac-9fcb-935c5252f251_mc_l.jpg" type="image/jpeg" media="(min-width: 980px)">
                            <source srcset="https://images.pb.pl/filtered/329a1626-9ae6-4915-aa2d-497314860efa/9210aacb-0e1a-52ac-9fcb-935c5252f251_xc_l.jpg" type="image/jpeg">
                            <img src="https://images.pb.pl/filtered/329a1626-9ae6-4915-aa2d-497314860efa/9210aacb-0e1a-52ac-9fcb-935c5252f251_mc_l.jpg" width="192" height="120" loading="lazy" alt="Jak obniżyć podatki">
                        </picture>
                        <span class="npb-l-bg-grad"></span>
                    </div>
                    <div class="npb-g-t-c-b">
                            <h2>
                                <span class="excerpt">Jak obniżyć podatki</span>
                            </h2>
                            <p class="npb-a-l npb-g-c-hidden-down">
                                <span class="excerpt">Podpowiadamy co&nbsp;krok po&nbsp;kroku należy zrobić, aby szybko, skutecznie i&nbsp;bezpiecznie zmienić formę opodatkowania i&nbsp;oszczędzić na&nbsp;podatkach dochodowych.</span>
                            </p>
                    </div>
                </div>
            </div>
        </div>
    </a>

                            </div>
                            <div class="npb-a-box npb-a-box-2">
                                    

    <a href="/wakacje-kredytowe-juz-pod-lupa-uokik-1156835">
        <div class="npb-g-c-t-up">
            <div class="npb-g-t-r">
                <div class="npb-g-t-c">
                    <div class="npb-g-t-c-l">
                        <picture>
                            <source srcset="https://images.pb.pl/filtered/c0066820-a078-4895-aeb0-a6795f2e3a5f/9ace707d-a939-5997-9dc6-89b6ee190961_mc_l.jpg" type="image/jpeg" media="(min-width: 980px)">
                            <source srcset="https://images.pb.pl/filtered/c0066820-a078-4895-aeb0-a6795f2e3a5f/9ace707d-a939-5997-9dc6-89b6ee190961_xc_l.jpg" type="image/jpeg">
                            <img src="https://images.pb.pl/filtered/c0066820-a078-4895-aeb0-a6795f2e3a5f/9ace707d-a939-5997-9dc6-89b6ee190961_mc_l.jpg" width="192" height="120" loading="lazy" alt="Wakacje kredytowe już pod lupą UOKiK">
                        </picture>
                        <span class="npb-l-bg-grad"></span>
                    </div>
                    <div class="npb-g-t-c-b">
                            <h2>
                                <span class="excerpt">Wakacje kredytowe już pod lupą UOKiK</span>
                            </h2>
                            <p class="npb-a-l npb-g-c-hidden-down">
                                <span class="excerpt">Ustawa wprowadzająca wakacje kredytowe jeszcze nie weszła w&nbsp;życie, a&nbsp;urząd antymonopolowy już ma&nbsp;zastrzeżenia do&nbsp;procesu przyjmowania wniosków.</span>
                            </p>
                    </div>
                </div>
            </div>
        </div>
    </a>

                            </div>
                            <div class="npb-a-box npb-a-box-2">
                                    

    <a href="/niemieckie-plany-onde-1156834">
        <div class="npb-g-c-t-up">
            <div class="npb-g-t-r">
                <div class="npb-g-t-c">
                    <div class="npb-g-t-c-l">
                        <picture>
                            <source srcset="https://images.pb.pl/filtered/ef79c757-0531-4675-b550-d52359b34948/3a4f43d1-c190-530a-9133-88d8ffc681ca_mc_l.jpg" type="image/jpeg" media="(min-width: 980px)">
                            <source srcset="https://images.pb.pl/filtered/ef79c757-0531-4675-b550-d52359b34948/3a4f43d1-c190-530a-9133-88d8ffc681ca_xc_l.jpg" type="image/jpeg">
                            <img src="https://images.pb.pl/filtered/ef79c757-0531-4675-b550-d52359b34948/3a4f43d1-c190-530a-9133-88d8ffc681ca_mc_l.jpg" width="192" height="120" loading="lazy" alt="Niemieckie plany Onde">
                        </picture>
                        <span class="npb-l-bg-grad"></span>
                    </div>
                    <div class="npb-g-t-c-b">
                            <h2>
                                <span class="excerpt">Niemieckie plany Onde</span>
                            </h2>
                            <p class="npb-a-l npb-g-c-hidden-down">
                                <span class="excerpt">Onde, budowniczy wiatraków z&nbsp;grupy Erbudu, chce pozyskać 250 mln EUR na&nbsp;budowę własnych instalacji, szuka stałego partnera i&nbsp;szykuje się do&nbsp;przejęcia firm w&nbsp;Niemczech.</span>
                            </p>
                    </div>
                </div>
            </div>
        </div>
    </a>

                            </div>
                        </div>
                    </div>
                    <footer class="npb-b-f"></footer>
                </section>
            </div>
        </div>
    </div>

<div class="npb-g-c npb-g-c-12 npb-g-mc-4 npb-g-lc-3 npb-g-mc-pr-up npb-sb npb-g-o-7">     <div class="npb-g-r">
        <div class="npb-g-c npb-g-c-12">
            <section class="npb-b npb-b-s-3 npb-b-al" style="margin-bottom: 20px;">
                <header class="npb-b-h" style="border-bottom: 6px solid #000; margin-bottom: 25px;" id="recomended">
                    <h4>Polecane</h4>
                </header>
                <div class="npb-g-r">
                    <div class="npb-g-c npb-g-c-12">
                                <div class="npb-box">
                                    


    <a href="/branza-beauty-chwyta-sie-internetu-988387">
        <div class="npb-g-c-t-down">
            <div class="npb-g-t-r">
                <div class="npb-g-t-c">
                    <div class="npb-g-t-c-l">
                        <picture>
                            <source srcset="https://images.pb.pl/filtered/83f19e2c-880a-4ccf-bfca-34335297d613/b065532f-cdf9-585e-92d4-85b614e424ad_mc_4.jpg" type="image/jpeg" media="(min-width: 980px)">
                            <source srcset="https://images.pb.pl/filtered/83f19e2c-880a-4ccf-bfca-34335297d613/b065532f-cdf9-585e-92d4-85b614e424ad_xc_l.jpg" type="image/jpeg">
                            <img src="https://images.pb.pl/filtered/83f19e2c-880a-4ccf-bfca-34335297d613/b065532f-cdf9-585e-92d4-85b614e424ad_xc_l.jpg" width="128" height="80" loading="lazy" alt="Branża beauty chwyta się internetu">
                        </picture>
                        <span class="npb-l-bg-grad"></span>
                    </div>
                    <div class="npb-g-t-c-b">
                        <h2><span class="excerpt">Branża beauty chwyta się internetu</span></h2>


                    </div>
                </div>
            </div>
        </div>
        <span class="npb-btn npb-btn-ats npb-g-mc-hidden-up" data-ats-id="988387" title="dodaj do schowka">             <span class="npb-l-i npb-l-i-star"></span>
        </span>
    </a>

                            </div>
                                <div class="npb-box">
                                    


    <a href="/zmorph-skaluje-sie-w-3d-986567">
        <div class="npb-g-c-t-down">
            <div class="npb-g-t-r">
                <div class="npb-g-t-c">
                    <div class="npb-g-t-c-l">
                        <picture>
                            <source srcset="https://images.pb.pl/filtered/f30d662a-0aad-49d2-9014-445ab0fff69c/39453ecf-fe96-518e-82d5-379cb01e5ca5_mc_4.jpg" type="image/jpeg" media="(min-width: 980px)">
                            <source srcset="https://images.pb.pl/filtered/f30d662a-0aad-49d2-9014-445ab0fff69c/39453ecf-fe96-518e-82d5-379cb01e5ca5_xc_l.jpg" type="image/jpeg">
                            <img src="https://images.pb.pl/filtered/f30d662a-0aad-49d2-9014-445ab0fff69c/39453ecf-fe96-518e-82d5-379cb01e5ca5_xc_l.jpg" width="128" height="80" loading="lazy" alt="ZMorph skaluje się w 3D">
                        </picture>
                        <span class="npb-l-bg-grad"></span>
                    </div>
                    <div class="npb-g-t-c-b">
                        <h2><span class="excerpt">ZMorph skaluje się w&nbsp;3D</span></h2>


                    </div>
                </div>
            </div>
        </div>
        <span class="npb-btn npb-btn-ats npb-g-mc-hidden-up" data-ats-id="986567" title="dodaj do schowka">             <span class="npb-l-i npb-l-i-star"></span>
        </span>
    </a>

                            </div>
                        <div class="npb-box">
                        </div>
                    </div>
                </div>
                <footer class="npb-b-f"></footer>
            </section>
        </div>
    </div>
</div>
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </div>

    <div class="npb-g-s-f npb-g-s-2">
        <div class="npb-g-r">
            <div class="npb-g-s">
                <div class="npb-g-r">

<div class="npb-g-c npb-g-c-12 npb-g-lc-10 npb-g-lc-push-2">
    <section class="npb-b npb-b-s-4 npb-b-al" style="margin-bottom: 20px;">
        <header class="npb-b-h" style="border-bottom: 6px solid #000;">
            <h4>Inspiracje Pulsu Biznesu</h4>
        </header>
        <div class="npb-g-r">
            <div class="npb-g-c npb-g-c-12">
                <div class="npb-a-box npb-a-box-1">
                        

    <a href="/rondo-w-cieniu-drzew-1134468">
        <div class="npb-g-c-t-up">
            <div class="npb-g-t-r">
                <div class="npb-g-t-c">
                    <div class="npb-g-t-c-l">
                        <picture>
                            <source srcset="https://images.pb.pl/filtered/8d672866-8e10-45cc-9747-b0240717cba4/264d5801-9cf6-5dfc-a1e5-12328da7f91f_lc_4.jpg" type="image/jpeg" media="(min-width: 1460px)">
                            <source srcset="https://images.pb.pl/filtered/8d672866-8e10-45cc-9747-b0240717cba4/264d5801-9cf6-5dfc-a1e5-12328da7f91f_mc.jpg" type="image/jpeg" media="(min-width: 980px)">
                            <source srcset="https://images.pb.pl/filtered/8d672866-8e10-45cc-9747-b0240717cba4/264d5801-9cf6-5dfc-a1e5-12328da7f91f_c_12.jpg" type="image/jpeg" media="(min-width: 401px)">
                            <source srcset="https://images.pb.pl/filtered/8d672866-8e10-45cc-9747-b0240717cba4/264d5801-9cf6-5dfc-a1e5-12328da7f91f_xc_12.jpg" type="image/jpeg">
                            <img src="https://images.pb.pl/filtered/8d672866-8e10-45cc-9747-b0240717cba4/264d5801-9cf6-5dfc-a1e5-12328da7f91f_xc_12.jpg" width="360" height="225" loading="lazy" alt="Rondo w cieniu drzew">
                        </picture>
                        <span class="npb-l-bg-grad"></span>
                    </div>
                    <div class="npb-g-t-c-b">
                            <h2>
                                <span class="excerpt">Rondo w&nbsp;cieniu drzew</span>
                            </h2>
                            <p class="npb-a-l npb-g-c-hidden-down">
                                <span class="excerpt">Michał Olszewski, wiceprezydent Warszawy, opowiada o&nbsp;sadzeniu drzew na&nbsp;rondzie Dmowskiego i&nbsp;spacerowych zachętach.</span>
                            </p>
                    </div>
                </div>
            </div>
        </div>
    </a>

                </div>
                <div class="npb-a-box npb-a-box-1">
                        

    <a href="/jak-urzedniczka-restauratorka-zostala-1131299">
        <div class="npb-g-c-t-up">
            <div class="npb-g-t-r">
                <div class="npb-g-t-c">
                    <div class="npb-g-t-c-l">
                        <picture>
                            <source srcset="https://images.pb.pl/filtered/6b9d3b67-b137-4566-97ab-f34d8ba1fb54/85f335a5-09f3-5a07-9dc1-d28e7c3d8ba3_lc_4.jpg" type="image/jpeg" media="(min-width: 1460px)">
                            <source srcset="https://images.pb.pl/filtered/6b9d3b67-b137-4566-97ab-f34d8ba1fb54/85f335a5-09f3-5a07-9dc1-d28e7c3d8ba3_mc.jpg" type="image/jpeg" media="(min-width: 980px)">
                            <source srcset="https://images.pb.pl/filtered/6b9d3b67-b137-4566-97ab-f34d8ba1fb54/85f335a5-09f3-5a07-9dc1-d28e7c3d8ba3_c_12.jpg" type="image/jpeg" media="(min-width: 401px)">
                            <source srcset="https://images.pb.pl/filtered/6b9d3b67-b137-4566-97ab-f34d8ba1fb54/85f335a5-09f3-5a07-9dc1-d28e7c3d8ba3_xc_12.jpg" type="image/jpeg">
                            <img src="https://images.pb.pl/filtered/6b9d3b67-b137-4566-97ab-f34d8ba1fb54/85f335a5-09f3-5a07-9dc1-d28e7c3d8ba3_xc_12.jpg" width="360" height="225" loading="lazy" alt="Jak urzędniczka restauratorką została">
                        </picture>
                        <span class="npb-l-bg-grad"></span>
                    </div>
                    <div class="npb-g-t-c-b">
                            <h2>
                                <span class="excerpt">Jak urzędniczka restauratorką została</span>
                            </h2>
                            <p class="npb-a-l npb-g-c-hidden-down">
                                <span class="excerpt">Justyna Kosmala zamieniła pracę urzędniczki na&nbsp;karierę restauratorki. Po&nbsp;pandemii wraca do&nbsp;rozwoju sieci Charlotte i&nbsp;szykuje kolejne projekty.</span>
                            </p>
                    </div>
                </div>
            </div>
        </div>
    </a>

                </div>
                <div class="npb-a-box npb-a-box-1">
                        

    <a href="/skad-sie-wzielo-polskie-narzekanie-to-spadek-po-chlopach-1129680">
        <div class="npb-g-c-t-up">
            <div class="npb-g-t-r">
                <div class="npb-g-t-c">
                    <div class="npb-g-t-c-l">
                        <picture>
                            <source srcset="https://images.pb.pl/filtered/cbdb4bd0-542c-455d-a483-9a873787c52f/d731d8f9-0d33-5f7a-ac9e-3a3b11574594_lc_4.jpg" type="image/jpeg" media="(min-width: 1460px)">
                            <source srcset="https://images.pb.pl/filtered/cbdb4bd0-542c-455d-a483-9a873787c52f/d731d8f9-0d33-5f7a-ac9e-3a3b11574594_mc.jpg" type="image/jpeg" media="(min-width: 980px)">
                            <source srcset="https://images.pb.pl/filtered/cbdb4bd0-542c-455d-a483-9a873787c52f/d731d8f9-0d33-5f7a-ac9e-3a3b11574594_c_12.jpg" type="image/jpeg" media="(min-width: 401px)">
                            <source srcset="https://images.pb.pl/filtered/cbdb4bd0-542c-455d-a483-9a873787c52f/d731d8f9-0d33-5f7a-ac9e-3a3b11574594_xc_12.jpg" type="image/jpeg">
                            <img src="https://images.pb.pl/filtered/cbdb4bd0-542c-455d-a483-9a873787c52f/d731d8f9-0d33-5f7a-ac9e-3a3b11574594_xc_12.jpg" width="360" height="225" loading="lazy" alt="Skąd się wzięło polskie narzekanie? To spadek po chłopach">
                        </picture>
                        <span class="npb-l-bg-grad"></span>
                    </div>
                    <div class="npb-g-t-c-b">
                            <h2>
                                <span class="excerpt">Skąd się wzięło polskie narzekanie? To&nbsp;spadek po&nbsp;chłopach</span>
                            </h2>
                            <p class="npb-a-l npb-g-c-hidden-down">
                                <span class="excerpt">Jesteśmy mistrzami świata w&nbsp;narzekaniu na&nbsp;niby — za&nbsp;czarnowidztwem kryje się bowiem… nasz niepoprawny optymizm.</span>
                            </p>
                    </div>
                </div>
            </div>
        </div>
    </a>

                </div>
            </div>
        </div>
        <footer class="npb-b-f"></footer>
    </section>
</div>
<div class="npb-g-c npb-g-c-12 npb-g-mc-6 npb-g-lc-5 npb-g-lc-push-2">
    <section class="npb-b npb-b-s-1 npb-a-breadcrumb">
        <header class="npb-b-h" style="border-bottom: 6px solid #000;">
            <h4><a href="/">Puls Biznesu</a></h4>
        </header>
        <div class="npb-b-c" style="padding: 10px 0; margin-bottom: 20px;">
<a class="npb-a-breadcrumb-i" href="https://www.pb.pl/kategoria/akcje/">Akcje</a> / <a class="npb-a-breadcrumb-i" href="https://www.pb.pl/sektor-technologiczny-czekaja-trudne-chwile-1156828">Sektor technologiczny czekają trudne chwile</a> </div>
    </section>
</div>
                </div>
            </div>
        </div>
    </div>



<!-- hit -->
<script type="text/javascript">
    (function () {
        var news_id = 1156828;
        nhi = new Image;
        if (npb.client_data.user_id == null) {
            user_id = 0
        } else {
            user_id = npb.client_data.user_id
        }
        nhi.src = '/new_hit/' + news_id + '?user_id=' + user_id + '&ref=&r=' + Math.random() + '&p=1&gc=1&site_id=1';
        document.querySelector('#npb-mw').appendChild(nhi);
    })();
</script><!-- hit -->
<script type="text/javascript">
    (function () {
        var object_id = "a2ef19e6-37a3-43e5-9411-35f2ee96cf43";
        var object_type = "article"
        hit = new Image;
        if (npb.client_data.user_id == null) {
            user_id = 0;
            email = null;
        } else {
            user_id = npb.client_data.user_id;
            email = npb.client_data.email;
        }

        if (email) {
            if (npb && npb.client_data.access_type === 'premium' || npb.client_data.access_type === 'basic') {
                user_status = "paid";
            } else if (npb && npb.client_data.access_type === 0) {
                user_status = "free_reg";
            } else {
                user_status = "free_unreg";
            }
            image = '/hits/' + object_id + '?email=' + email + '&object_type=' + object_type + '&user_status=' + user_status + '&v=' + Math.random();
            hit.src = image;
            document.querySelector('#npb-mw').appendChild(hit);
        }
    })();
</script>
</div> 
<div class="piano-wrapper nlt-signup-ribbon">
    <img class="nlt-signup-ribbon__close-btn" src="/static/img/icon-close.svg" alt="Ikona zamknięcia">
    <div id="nlt_signup_ribbon"></div>
</div>

<div class="piano-wrapper recommended-articles">
    <div id="recommended_articles"></div>
</div>

<script>
document.querySelector('.nlt-signup-ribbon__close-btn').addEventListener('click', function() {
    document.querySelector('.nlt-signup-ribbon').classList.add('-hidden');
});
</script>


<footer class="npb-mf npb-mf-ap">
  <div class="npb-g-s">
    <div class="npb-g-r">
      <div class="npb-g-c npb-g-c-12">
        <section class="cockroach">
    <input class="cockroach__state" type="checkbox" name="CockroachState" id="CockroachState">
    <div class="cockroach__target">
            <ul class="cockroach__list">
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/wiadomosc/Leasing-konsumencki-dla-kogo-jak-dziala-i-czy-warto-7521079.html" title="Leasing konsumencki">Leasing konsumencki</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/smart/narzedzia/przelicznik-walut-kalkulator-online" title="Przelicznik walut">Przelicznik walut</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/smart/konta-oszczednosciowe" title="Ranking kont oszczędnościowych">Ranking kont oszczędnościowych</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/smart/lokaty" title="Lokaty">Lokaty</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/smart/kredyty-gotowkowe" title="Ranking kredytów gotówkowych">Ranking kredytów gotówkowych</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/smart/konta-firmowe" title="Ranking kont firmowych">Ranking kont firmowych</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://blogbank.pl/" title="blogbank.pl">blogbank.pl</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/smart/konta-bankowe" title="https://www.bankier.pl/smart/konta-bankowe">https://www.bankier.pl/smart/konta-bankowe</a></li>
            </ul>
            <ul class="cockroach__list">
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/waluty/kursy-walut/nbp/USD" title="Kurs Dolara">Kurs Dolara</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/waluty/kursy-walut/nbp/EUR" title="Kurs Euro">Kurs Euro</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/waluty/kursy-walut/nbp" title="Kursy walut">Kursy walut</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/puls-inwestora/dywidendy/" title="Dywidendy">Dywidendy</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/wiadomosc/Sesje-Elixir-7368466.html" title="Sesje elixir">Sesje elixir</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/tarcza-antykryzysowa" title="Tarcza antykryzysowa">Tarcza antykryzysowa</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/konferencje/" title="Konferencje">Konferencje</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://smartoferty.pl/" title="smartoferty.pl">smartoferty.pl</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/smart/kredyty-hipoteczne" title="Kredyt hipoteczny Bankier SMART">Kredyt hipoteczny Bankier SMART</a></li>
            </ul>
            <ul class="cockroach__list">
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/waluty/kursy-walut/forex" title="Forex">Forex</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://mambiznes.pl/startupy" title="Startup">Startup</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/mieszkaniowe/stopy-procentowe/wibor" title="Wibor">Wibor</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://pulsmedycyny.pl/jestem-smutny-nie-moge-spac-zapominam-875168" title="Depresja">Depresja</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://pulsmedycyny.pl/choroba-hashimoto-rozwija-sie-w-ukryciu-887596" title="Choroba Hashimoto">Choroba Hashimoto</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://pulsmedycyny.pl/odra-grozna-nie-tylko-dla-dzieci-przebieg-choroby-u-doroslych-moze-byc-jeszcze-ciezszy-944548" title="Odra u dorosłych">Odra u dorosłych</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://pulsmedycyny.pl/ostre-zapalenie-zatok-przynosowych-jest-zwykle-nastepstwem-kataru-891443" title="Ostre zapalenie zatok">Ostre zapalenie zatok</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://mambiznes.pl/poradniki/zarzadzanie" title="Biznes plan">Biznes plan</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/smart/narzedzia/kalkulator-kredytowy" title="Kalkulator kredytu gotówkowego">Kalkulator kredytu gotówkowego</a></li>
            </ul>
            <ul class="cockroach__list">
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/program-pit/" title="Program pit">Program pit</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/pit-online/" title="Pit online">Pit online</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/ulga-rehabilitacyjna/" title="Ulga rehabilitacyjna">Ulga rehabilitacyjna</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/ulga-prorodzinna/" title="Ulga na dziecko">Ulga na dziecko</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/ulga-internet/" title="Ulga na internet">Ulga na internet</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/kiedy-zwrot-podatku/" title="Kiedy zwrot podatku">Kiedy zwrot podatku</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/kiedy-zwrot-podatku/" title="Zwrot podatku">Zwrot podatku</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/pit-pracodawca/" title="pit 11 do kiedy">pit 11 do kiedy</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/wiadomosc/Kogo-czeka-zmiana-pracy-w-2022-roku-a-gdzie-pensje-wzrosna-najwyzej-Sprawdzamy-8198164.html" title="Kogo czeka zmiana pracy w 2022 roku">Kogo czeka zmiana pracy w 2022 roku</a></li>
            </ul>
            <ul class="cockroach__list">
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/skala-podatkowa-pit/" title="Progi podatkowe">Progi podatkowe</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/pit-37-online/" title="Pit 37">Pit 37</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/twoj-e-pit/" title="Twój e-pit">Twój e-pit</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/pit" title="Rozliczenie PIT">Rozliczenie PIT</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/koszty-uzyskania-przychodu-pit/" title="Koszty uzyskania przychodu">Koszty uzyskania przychodu</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/kwota-wolna-od-podatku/" title="Kwota wolna od podatku">Kwota wolna od podatku</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pit.pl/" title="Pity">Pity</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/kredyt-hipoteczny-kupno-mieszkania-krok-po-kroku-1101134" title="Kredyt hipoteczny: kupno mieszkania krok po kroku">Kredyt hipoteczny: kupno mieszkania krok po kroku</a></li>
            </ul>
            <ul class="cockroach__list">
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/moto/rejestracja-samochodu-krok-po-kroku-koszty-dokumenty-3386/" title="Rejestracja pojazdu">Rejestracja pojazdu</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://zgarnijpremie.pl/" title="Zgarnij premię">Zgarnij premię</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/moto/winiety-ue-gdzie-kupic-ile-kosztuja-ceny-online-oplaty-drogowe-3646/" title="Winiety">Winiety</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/wiadomosc/Jak-wypowiedziec-umowe-o-prace-2353767.html" title="Wypowiedzenie umowy o pracę">Wypowiedzenie umowy o pracę</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.bankier.pl/narzedzia/kalkulator-placowy" title="Kalkulator wynagrodzeń">Kalkulator wynagrodzeń</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://mambiznes.pl" title="Pomysł na własny biznes ">Pomysł na własny biznes </a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/kredyt-gotowkowy-samochodowy-czy-leasing-jak-sfinansowac-zakup-samochodu-1101149" title="Kredyt gotówkowy, samochodowy czy leasing?">Kredyt gotówkowy, samochodowy czy leasing?</a></li>
            </ul>
            <ul class="cockroach__list">
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/konferencje/learning-development-strategies-5821e3e1-f271-4824-9f37-0c5fe1c2aa27" title="Learning&amp;Development Strategies">Learning&amp;Development Strategies</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/konferencje/sprawna-obsluga-reklamacji-prawo-i-praktyka-164f3c8c-3fbf-4999-8880-c4dcb57f6f5a" title="Sprawna obsługa reklamacji - prawo i praktyka">Sprawna obsługa reklamacji - prawo i praktyka</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/konferencje/sales-team-level-up-6820a3dd-d28f-4a02-8ba9-d292f8fc9867" title="Sales Team Level Up">Sales Team Level Up</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/konferencje/modern-production-summit-b1cbda6b-ce1e-45b4-9ca6-ff5857f9f7f8" title="Modern Production Summit">Modern Production Summit</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/konferencje/kodeks-spolek-handlowych-najnowsze-zmiany-prawne-5c8d666d-7ba6-47bf-ae70-2e1aeada0127" title="KODEKS SPÓŁEK HANDLOWYCH - najnowsze zmiany prawne">KODEKS SPÓŁEK HANDLOWYCH - najnowsze zmiany prawne</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/konferencje/ochrona-danych-osobowych-i-innych-informacji-doswiadczenia-i-trendy-w-2022-r-42541672-da58-4a1a-839a-3391276b6b54" title="Ochrona danych osobowych i innych informacji - doświadczenia i trendy w 2022 r.">Ochrona danych osobowych i innych informacji - doświadczenia i trendy w 2022 r.</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/konferencje/hr-summit-2022-7c6d93fa-934f-405d-9160-fc33cc80b186" title="HR Summit 2022">HR Summit 2022</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/konferencje/research-innovation-forum-4f5fdb5f-91b7-4d8c-bb74-7b01974882e5" title="RESEARCH &amp; INNOVATION FORUM">RESEARCH &amp; INNOVATION FORUM</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/konferencje/xv-forum-dyrektorow-dzialow-prawnych-453c7c1a-4a50-411a-9d5b-7aa8a85264d4" title="XV Forum Dyrektorów Działów Prawnych">XV Forum Dyrektorów Działów Prawnych</a></li>
                    <li class="cockroach__item"><a class="cockroach__link" href="https://www.pb.pl/konferencje/digital-friendly-brands-index-b2f04e22-6d8f-4a86-b810-5f6838a48014" title="Digital Friendly Brands&#39; Index">Digital Friendly Brands&#39; Index</a></li>
            </ul>
    </div>
    <label for="CockroachState" class="cockroach__trigger">Tematy&nbsp;</label>
</section>
      </div>
    </div>
    <div class="npb-g-r">
      <div class="npb-g-c npb-g-c-12 npb-g-mc-6 npb-mf-promo npb-g-pr" id='footer-area'>
      <div class="npb-g-r" id="activate-button-container">
        <div class="npb-g-c npb-g-c-4">
           <img src="/static/img/footer_sub.jpg" alt="Dołącz do naszej społeczności już teraz" class="npb-r-image" width="248" height="189" loading="lazy">
        </div>
        <div class="npb-g-c npb-g-c-8">

            <p>W „Pulsie Biznesu" odpowiadamy&nbsp;na pytania co, jak i dlaczego - chcemy pokazywać tylko prawdziwy obraz rzeczywistości.</p>
            <p>Dołącz do naszej społeczności już teraz.</p>

          <a class="npb-btn npb-btn-white" href="https://www.pb.pl/subskrypcja/" onclick="
dataLayer.push({
      'eventCategory': 'E-commerce',
      'eventAction': 'Akcje rozszerzonego e-commerce',
      'eventLabel': 'Kampania wewnetrzna - Oferta, stopka',
      'eventValue': 0,
      'eventNonInteraction': true,
      'event': 'zdarzenie_enh_ecom',
      'ecommerce': {
          'promoClick': {
              'promotions': [
                  {
                      'id':  'article ID:1156828' ,
                      'name': 'Footer:offer',
                      'creative': 'display',
                      'position': 'footer'
                  }
              ]
          }
      }
});

"> SPRAWDŹ</a>
        </div>
      </div>
    </div>
<script>
window.onscroll = function (e) {
    var positionToLaunch = window.scrollY + window.innerHeight - 75;
    var buttonAreaHeight = document.getElementById('activate-button-container').clientHeight;
    if (window.innerWidth < 980) {
        positionToLaunch = window.scrollY + window.innerHeight - buttonAreaHeight;
    }
    if (positionToLaunch >= document.getElementById('footer-area').offsetTop) {
        dataLayer.push({
            'eventCategory': 'E-commerce',
            'eventAction': 'Akcje rozszerzonego e-commerce',
            'eventLabel': 'Kampania wewnetrzna - Oferta, stopka',
            'eventValue': 0,
            'eventNonInteraction': true,
            'event': 'zdarzenie_enh_ecom',
            'ecommerce': {
                'promoView': {
                    'promotions': [
                        {
                            'id':  'article ID:1156828' ,
                            'name': 'Footer:offer',
                            'creative': 'display',
                            'position': 'footer'
                        }
                    ]
                }
            }
        });
        window.onscroll = null;
    }
}
</script>
      <div class="npb-g-c npb-g-c-12 npb-g-mc-3">
        <span class="npb-h6">Puls Biznesu</span>
        <ul class="npb-nav npb-mf-nav npb-mf-nav-0" role="menu">
                <li>
                    <a href="https://bonnier.pl/grupa-bonnier/kim-jestesmy/">O nas</a>
                </li>
                <li>
                    <a href="https://bonnier.pl/reklama/dlaczego-my/">Reklama</a>
                </li>
                <li>
                    <a href="https://www.pb.pl/kontakt">Kontakt</a>
                </li>
                <li>
                    <a href="https://bonnier.pl/kariera/oferty-pracy/">Praca</a>
                </li>
                <li>
                    <a href="https://apps.bonnier.pl/img/regulamin.pdf">Regulamin</a>
                </li>
                <li>
                    <a href="https://notowania.pb.pl">Notowania</a>
                </li>
                <li>
                    <a href="/puls-inwestora/">Puls Inwestora</a>
                </li>
                <li>
                    <a href="/puls-innowacji/">Innowacje</a>
                </li>
                <li>
                    <a href="/puls-firmy/">Firma</a>
                </li>
                <li>
                    <a href="/pogodzinach">Po Godzinach</a>
                </li>
                <li>
                    <a href="https://www.pb.pl/gazele/">Gazele</a>
                </li>
                <li>
                    <a href="https://www.pb.pl/konferencje">Konferencje</a>
                </li>
                <li>
                    <a href="/newslettery">Newslettery</a>
                </li>
                <li>
                    <a href="/faq/">FAQ</a>
                </li>
        </ul>
    </div>
      <div class="npb-g-c npb-g-c-12 npb-g-mc-3">
        <span class="npb-h6">Grupa Bonnier</span>
        <ul class="npb-nav npb-mf-nav npb-mf-nav-1" role="menu">
                <li>
                    <a href="https://www.bankier.pl">Bankier.pl</a>
                </li>
                <li>
                    <a href="https://www.pit.pl">Pit.pl</a>
                </li>
                <li>
                    <a href="https://dyskusja.biz">Dyskusja.biz</a>
                </li>
                <li>
                    <a href="https://mambiznes.pl">Mambiznes.pl</a>
                </li>
                <li>
                    <a href="https://prnews.pl">PRnews.pl</a>
                </li>
                <li>
                    <a href="https://www.arslege.pl">Arslege.pl</a>
                </li>
                <li>
                    <a href="https://pulsmedycyny.pl">Puls Medycyny</a>
                </li>
                <li>
                    <a href="https://pulsfarmacji.pl">Puls Farmacji</a>
                </li>
                <li>
                    <a href="https://www.systempartnerski.pl">System Partnerski</a>
                </li>
                <li>
                    <a href="https://zgarnijpremie.pl/">Zgarnij Premię</a>
                </li>
                <li>
                    <a href="https://spotdata.pl/">Spotdata.pl</a>
                </li>
                <li>
                    <a href="https://konsylium24.pl/">Konsylium24</a>
                </li>
                <li>
                    <a href="https://media.pb.pl/">Media</a>
                </li>
        </ul>
    </div>
    </div>
    <div class="npb-g-r">
      <div class="npb-g-c npb-g-c-12 npb-g-mc-6">
        <ul class="npb-nav" role="menu">
          <li>
            Bonnier&nbsp;&copy;&nbsp;2022&nbsp;Puls&nbsp;Biznesu&nbsp;&#124;&nbsp;
          </li>
          <li>
              <a href="https://apps.bonnier.pl/img/polityka_plikow_cookies.pdf" target="_blank">Serwis używa cookies&nbsp;&#124;&nbsp;</a>
          </li>
          <li>
              <a href="https://apps.bonnier.pl/img/polityka_prywatnosci_bbp.pdf" target="_blank">Polityka Prywatności</a>
          </li>
        </ul>
      </div>
    </div>
  </div>
    <div class="npb-g-s-f npb-g-s-0">
        <div class="npb-g-r">
        </div>
    </div>
</footer>    </div>

    <div id="piano-bottom-widget" class="bottom-widget"></div>


<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true"><div class="pswp__bg"></div><div class="pswp__scroll-wrap"><div class="pswp__container"><div class="pswp__item"></div><div class="pswp__item"></div><div class="pswp__item"></div></div><div class="pswp__ui pswp__ui--hidden"><div class="pswp__top-bar"><div class="pswp__counter"></div> <button class="pswp__button pswp__button--close" title="Zamknij (Esc)"></button> <button class="pswp__button pswp__button--fs" title="Pełny ekran"></button> <button class="pswp__button pswp__button--zoom" title="Powiększ/Pomniejsz"></button><div class="pswp__preloader"><div class="pswp__preloader__icn"><div class="pswp__preloader__cut"><div class="pswp__preloader__donut"></div></div></div></div></div><div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap"><div class="pswp__share-tooltip"></div></div> <button class="pswp__button pswp__button--arrow--left" title="Poprzedni (lewa strzałka)"> </button> <button class="pswp__button pswp__button--arrow--right" title="Następny (prawa strzałka)"> </button><div class="pswp__caption"><div class="pswp__caption__center"></div></div></div></div></div>    <script async src="/static/js/npb.min.js?v=220504"></script>
<script>function dtx_data () { return { mt_pid: 6257 }}</script>
<script async src="//cdn.dtxngr.com/init.js"></script><script type="text/javascript" async src="/static/js/npb.a.min.js?v=2007151"></script>

<script>
var __cp={"id":"rGO7q4e8_w7bbUFc0tScFQ5GD7uml49wVZdCbBLIwOc","version":"1.1"};(function(window,document){var cp=document.createElement('script');cp.type='text/javascript';cp.async=true;cp.src="++cdn-widget.callpage.io+build+js+callpage.js".replace(/[+]/g,'/').replace(/[=]/g,'.');var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(cp,s);if(window.callpage){alert('You could have only 1 CallPage code on your website!');}else{window.callpage=function(method){if(method=='__getQueue'){return this.methods;}else if(method){if(typeof window.callpage.execute==='function'){return window.callpage.execute.apply(this,arguments);}else{(this.methods=this.methods||[]).push({arguments:arguments});}}};window.callpage.__cp=__cp;window.callpage('api.button.autoshow');}})(window,document);
</script>
<script type="text/javascript">
function onPswpGalleryImageLoad(pfn) {
    dataLayer.push({'eventCategory': 'Akcje uzytkownika', 'eventAction': 'Wyświetl zdjęcie', 'eventLabel': pfn, 'eventValue': 0, 'eventNonInteraction': false, 'event': 'zdarzenie' });
}
</script>
<script type="text/javascript">
gemius_event('_action_','','author=Mikołaj Śmiłowski');
gemius_event('_action_','','section=Puls Inwestora');
gemius_event('_action_','','category=Makroekonomia');
gemius_event('_action_','','category=Akcje');
</script>



<script>
    (function(src) {
        var a = document.createElement("script");
        a.type = "text/javascript";
        a.async = true;
        a.src = src;
        var b = document.getElementsByTagName("script")[0];
        b.parentNode.insertBefore(a, b)
    })("//c2.exp.pb.pl/xbuilder/experience/load?aid=BNGVx5sKpe");
</script>


<script>
    tp = window.tp || []; 
    tp.push(['setUsePianoIdUserProvider', true]); 

    
    tp.push(["setTags", ['Puls Inwestora (SECTION)','Makroekonomia (CATEGORY)','Akcje (CATEGORY)','141/2022 (ISSUE)','Published in e-wydanie','article (PAGE TYPE)']]);
    


        tp.push(["setContentAuthor", "Mikołaj Śmiłowski"]);

        tp.push(["setContentCreated", "2022-07-26T18:00:00Z"]);

        tp.push(["setContentSection", "closed"]);



        tp.push(["setCustomVariable", "gate_status", "1"]);

    

    tp.push(["init", function() {
        tp.enableGACrossDomainLinking('UA-44780777-2')
    }]);

    tp.push(["addHandler", "showOffer", () => {
        document.querySelectorAll("#paywall ~ *").forEach((x) => {
            x.hidden = true;
        });
    } ]);

    tp.push(["addHandler", "checkoutSelectTerm", function(termDetails, iframeId){
        console.log("udało się", termDetails, iframeId);
} ]);
</script>


<script>
    tp = window.tp || [];
    var pattern = /verification_code=.*$/; // /[?&]?verification_code=.*$/; // ?verification_code=[\d\D]{14}
    var url = window.location.href;
    var param = url.split('?')[1];

    if (param && pattern.test(param) && localStorage.getItem('pdor')) {

        var pdor_data = JSON.parse(localStorage.getItem('pdor'));

        if (pdor_data.url && !pdor_data.hasOwnProperty('ut')) {
            var pdor_url = decodeURIComponent(pdor_data.url);
            pdor_url = pdor_url + (pdor_url.split('?')[1] ? '&':'?') + param;

            pdor_data.ut = new Date().getTime();
            localStorage.setItem('pdor', JSON.stringify(pdor_data));

            window.location.href = pdor_url;
        }
    }

    tp.push(["addHandler", "checkoutCustomEvent", function(event) {
        if (event.eventName === "pdorSetData") {
            if (typeof Storage !== "undefined") {
                // piano double optin redirect
                var pdor_data = { 
                    ref: encodeURIComponent(document.referrer) || null
                    , url: encodeURIComponent(window.location.href) || null
                    , t: new Date().getTime()
                };

                localStorage.setItem('pdor', JSON.stringify(pdor_data));
            }
        }
    }]);
</script>

<script>
    tp = window.tp || [];

    if (localStorage.getItem('pidr')) {
        const pidr_data = JSON.parse(localStorage.getItem('pidr'));
        localStorage.removeItem('pidr');
        if (pidr_data.path) {
            window.location.href = decodeURIComponent(pidr_data.path);
        }
    }

    tp.push(["addHandler", "loginSuccess", function(data) {
        if (["/konto/logowanie/", "/konto/przypomnienie-hasla/", "/konto/rejestracja/", "/urodziny"].indexOf(window.location.pathname) !== -1) {
            const param = window.location.href.split("?")[1];

            const localStorageItemName = "/urodziny".indexOf(window.location.pathname) !== -1 ? 'pidr_ba' : 'pidr';
            let path = "/";

            if (param && (/next=.*$/).test(param)) {
                path = param.replace("next=", "");
            }

            if (typeof Storage !== "undefined") {
                // piano id redirect
                var pidr_data = { 
                    path: path
                    , t: new Date().getTime()
                };

                localStorage.setItem(localStorageItemName, JSON.stringify(pidr_data));
                
            }
        }
    }]);
</script>

<script>

    tp = window.tp || [];

    tp.push(["addHandler", "checkoutComplete", function(conversion) { 
        console.log('PC_ checkoutComplete conversion ', conversion); 
    }]);

    tp.push(["addHandler", "checkoutClose", function(event) { 
        // The event object contains information about the state of closed modal 
        console.log('PC_ checkoutClose event event.state ', event, event.state);

        switch (event.state) { 
            case 'checkoutCompleted': 
                // User completed the purchase and now has access 
                // Usually it's a good practice to reload the page 
                console.log('PC_ checkoutClose.checkoutCompleted');
                break; 
            case 'alreadyHasAccess': 
                // User already has access 
                // This state could be a result of user logging in during checkout process 
                // Usually it's a good practice to reload the page here as well
                console.log('PC_ checkoutClose.alreadyHasAccess');
                break; 
            case 'voucherRedemptionCompleted': 
                // User redeemed a gift voucher 
                // Normally gift redemption happens on a landing page, 
                // so logically it makes sense to redirect user to a home page after this 
                console.log('PC_ checkoutClose.voucherRedemptionCompleted');
                break; 
            case 'close': 
                // User did not complete the purchase and simply closed the modal 
                console.log('PC_ checkoutClose.close')
                break;
        } 
    }]);

    tp.push(["addHandler", "checkoutError", function(errorData) { 
        // alert("Error! " + errorData.message); 
        console.log('PC_ checkoutError errorData, errorData.message ', errorData, errorData.message); 
    }]);

    tp.push(["addHandler", "checkoutSelectTerm", function(termDetails, iframeId) {
          // Your code after the user selects a term 
        console.log('PC_ checkoutSelectTerm termDetails, iframeId ', termDetails, iframeId);
    }]);

    tp.push(["addHandler", "checkoutStateChange", function(stateView) { 
        console.log('PC_ checkoutStateChange stateView ', stateView); 
    }]);

    tp.push(["addHandler", "showOffer", function(offerParams) { 
        console.log('PC_ showOffer offerParams ', offerParams); 
    }]);

    tp.push(["addHandler", "showTemplate", function(templateParams) { 
        // Your code after template has been shown 
        console.log('PC_ showTemplate templateParams ', templateParams);
    }]);

    tp.push(["addHandler", "startCheckout", function() { 
        // Your code after checkout has started 
        console.log('PC_ startCheckout');
    }]);

    tp.push(["addHandler", "submitPayment", function(data) { 
        // Your code after payment is submitted
        console.log('PC_ submitPayment data ', data);
    }]);


    if (tp.pianoId && tp.pianoId.isUserValid()) {
        var user = tp.pianoId.getUser();

        console.log('PC_ user ', user);
    }

</script><script>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</script><script type="text/javascript">
    ;!function(){
        window.PianoESPConfig = {
            id: 263
        }
        var e=document.createElement("script");e.setAttribute("id","pnesplucidsdksel"),e.type="text/javascript",e.src="//api-esp-eu.piano.io/public/sdk/v04/sdk.js?v="+(localStorage&&localStorage.lucidsdkver||"xxx"),e.async=!0,document.getElementsByTagName("script")[0].parentNode.appendChild(e);
    }();
</script>
<script>
tp = window.tp || [];

var newsletter_list_signup = [];
var newsletter_list_signoff = [];

var newsletter_footer = document.querySelector('.newsletters-footer');

tp.push(["addHandler", "customEvent", function(event) {
    switch (event.eventName) {
        case 'email-signup':

            var id_newsletter = parseInt(event.params.newsletter);

            if(newsletter_list_signoff.indexOf(id_newsletter) === -1) {
                newsletter_list_signup.push(id_newsletter);
            } else {
                newsletter_list_signoff.splice(newsletter_list_signoff.indexOf(id_newsletter), 1);
            }

            if(event.params.nlt) {
                var params = JSON.parse(event.params.params);
                var iframe_id = params.iframeId || '';
                var sendNewsletterLists = window.sendNewsletterLists;
                if(sendNewsletterLists) {
                    sendNewsletterLists(iframe_id);
                }
            }

            break;

        case 'email-signoff':

            var id_newsletter = parseInt(event.params.newsletter);

            if(newsletter_list_signup.indexOf(id_newsletter) === -1) {
                newsletter_list_signoff.push(id_newsletter);
            } else {
                newsletter_list_signup.splice(newsletter_list_signup.indexOf(id_newsletter), 1);
            }

            break;
    }

    if(newsletter_footer) {
        if(!newsletter_list_signup.length && !newsletter_list_signoff.length) {
            newsletter_footer.classList.remove('-show');
        } else {
            newsletter_footer.classList.add('-show');
            newsletter_footer.classList.remove('-info');
        }
    }

}]);

</script>
<script type="text/javascript">
    function setCookie(name,value,days) {
        var expires = "";
        if (days) {
            var date = new Date();
            date.setTime(date.getTime() + (days*24*60*60*1000));
            expires = "; expires=" + date.toUTCString();
        }
        document.cookie = name + "=" + (value || "")  + expires + "; path=/";
    }
    function getCookie(name) {
        var nameEQ = name + "=";
        var ca = document.cookie.split(';');
        for(var i=0;i < ca.length;i++) {
            var c = ca[i];
            while (c.charAt(0) === ' ') c = c.substring(1,c.length);
            if (c.indexOf(nameEQ) !== -1) {
                console.log(c);
                return {
                    'firm': c.substring(0, c.indexOf(nameEQ)),
                    'value': c.substring(c.indexOf(nameEQ) + nameEQ.length,c.length)
                };
            }
        }
        return null;
    }
    // setCookie('Bat-Entered','1',7);
    // setCookie('Bat-Decision','0',7);

    var entered = getCookie('-Entered');
    var decision = getCookie('-Decision');
    // console.log('e: '+ entered.firm.toLowerCase() + ' ' + entered.value);
    // console.log('d: '+ decision.firm.toLowerCase() + ' ' + decision.value);


    if (entered && entered.value === "1" && entered.firm !== "" && entered.firm.toLowerCase() !== "asseco"){
        if(decision === null || (entered.firm.toLowerCase() === decision.firm.toLowerCase() && decision.value === '-1')){
            // console.log('redirect');
            setTimeout(function(){
                window.location.href = '/subskrypcja/firmy/'+entered.firm.toLowerCase();
            }, 7000);
        }
    }
</script>
</body>
</html>